Quote (Vector) and Search (Navigator): Slow Response Times
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting Quote (Vector) and Search (Navigator) . Thank you for your patience.
Posted Jun 21, 2023 - 12:37 CDT
Identified
We have identified the issue impacting Quote (Vector) and Search (Navigator). Access to these systems should be restored shortly.
Posted Jun 21, 2023 - 11:51 CDT
This incident affected: Vector and Navigator.