Issues with Online Systmes
Incident Report for IMT Apps
Resolved
We have resolved the issues affecting the online systems. Thank you for your patience.
Posted Apr 16, 2020 - 08:01 CDT
Investigating
We have been notified of issues currently affecting our online systems. Our team is investigating and will continue to update you as we learn more.
Posted Apr 16, 2020 - 07:42 CDT
This incident affected: Vector, Claims, Imaging, WebInquiry, Other, and Navigator.