Documents not loading in Spectrum

Incident Report for IMT Apps

Resolved

We have resolved the issue affecting generating documents in Spectrum Thank you for your patience.
Posted Jul 29, 2026 - 17:07 CDT

Investigating

We have been notified of an issue currently affecting missing documents in Spectrum. Our team is investigating and will continue to provide updates as we learn more.
Posted Jul 29, 2026 - 16:12 CDT
This incident affected: Spectrum.