Attachments not saving in Cabinet for Spectrum

Incident Report for IMT Apps

Resolved

We have resolved the issue affecting uploading/saving attachments to the Cabinet in Spectrum. Thank you for your patience.
Posted Oct 31, 2025 - 14:07 CDT

Identified

We have been notified of an issue that is affecting new attachments not getting uploaded/saved in the Cabinet for Spectrum. We will be releasing a fix tonight (10/31) for this issue. In the meantime, if possible, we would suggest not uploading any new attachments. We apologize for the inconvenience.
Posted Oct 31, 2025 - 10:57 CDT
This incident affected: Spectrum.