Online Systems are Slow
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting the issues with our some of the Online Products. Thank you for your patience.
Posted Feb 26, 2020 - 12:18 CST
Monitoring
We are monitoring the issue affecting some of our Online Product. We will continue to update you. Thank you for your patience.
Posted Feb 26, 2020 - 10:04 CST
This incident affected: Vector, Claims, Imaging, and Navigator.