Partner Connection: Grinnell Rating in Quote/Apps and APPS

Incident Report for IMT Apps

Resolved

We have been notified that Grinnell has resolved the issue affecting Grinnell Liability for APPS clients in the APPS system and in Quote/Apps. Thank you for your patience.
Posted Jun 05, 2026 - 08:49 CDT

Update

We are continuing to investigate this issue.
Posted Jun 05, 2026 - 08:48 CDT

Investigating

We have been notified by Grinnell of an issue currently affecting rating of Grinnell Liability for APPS clients in the APPS system and in Quote/Apps. Our team is being updated by Grinnell and will continue to provide updates as we learn more.
Posted Jun 05, 2026 - 08:47 CDT
This incident affected: Quote/Apps (Vector).