Unable to access IMT Software Services Dashboard

Incident Report for IMT Apps

Resolved

We have resolved the issue affecting access to the IMT Software Services dashboard. Thank you for your patience.
Posted Mar 19, 2026 - 08:35 CDT

Identified

Update: We have identified the issue that is not allowing access to the IMT Software Services dashboard and working on the resolution.
Posted Mar 19, 2026 - 08:16 CDT

Investigating

At this time you are not able to log into the IMT Software Services dashboard. Our team is investigating and will continue to provide updates as we learn more.
Posted Mar 19, 2026 - 07:55 CDT
This incident affected: Quote/Apps (Vector), Claims Management, Imaging, Web Inquiry, Dashboard, Lender Notifications, Other, Policy Search (Navigator), Spectrum, and Accounting (Spectrum).