Web Payments in MIPS and Web Inquiry are down
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting Web Payments in Web Inquiry and MIPS. Thank you for your patience.
Posted Nov 21, 2019 - 08:31 CST
Update
We are continuing to investigate this issue.
Posted Nov 21, 2019 - 08:20 CST
Investigating
We have been notified of an issue currently affecting Web Payments in Web Inquiry and MIPS. Our team is investigating and will continue to update you as we learn more.
Posted Nov 21, 2019 - 07:58 CST
This incident affected: WebInquiry and Other.