Online Systems are Slow
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting our Online Systems being slow or non-responsive. Thank you for your patience.
Posted Feb 28, 2020 - 08:36 CST
Monitoring
We believe we have resolved the issue that was affecting the Online Products to run slow. Things should be back to normal. Please let us know if you continue to experience issues. Thank you for your patience.
Posted Feb 27, 2020 - 13:00 CST
Update
Online systems are slow or unresponsive. Our team is actively working to resolve the issue. We will continue to update you as we learn more.

Systems included, but not limited to: Vector(Quote), Navigator, Claims, Imaging
Posted Feb 27, 2020 - 11:45 CST
Investigating
We are experiencing slowness with our Online Systems this morning. Our team is investigating and will continue to update you as we learn more.
Posted Feb 27, 2020 - 08:30 CST
This incident affected: Vector, Claims, Imaging, Other, and Navigator.