IMT Internet Outage - Quote and Navigator/Search for Policies Down
Incident Report for IMT Apps
Resolved
The widespread internet outage with major providers in the Central US has been resolved. All systems are back. Thank you for your patience.
Posted Aug 23, 2019 - 12:30 CDT
Update
There appears to be a widespread internet outage with major providers in the Central US. At the present time, our staff is without broad email or phone capabilities. Also, Quote and Navigator/Inquiry are down as part of the outage.

We apologize for the inconvenience and will post and update as soon as we have additional information.
Posted Aug 23, 2019 - 10:34 CDT
Update
There appears to be a widespread internet outage with major providers in the Central US. At the present time, our staff is without broad email or phone capabilities.

We apologize for the inconvenience and will post and update as soon as we have additional information.
Posted Aug 23, 2019 - 10:03 CDT
Investigating
We have been notified of an issue currently affecting the Internet in at the IMT Office. This would impact Vector/Quote and Navigator/Policy Search. Will continue to update you as we learn more.
Posted Aug 23, 2019 - 09:42 CDT
This incident affected: Vector and Navigator.