Electronic Payments - Unable to Make Credit Card Payments with ReliaFund

Incident Report for IMT Apps

Update

**UPDATE: ReliaFund and their vendor are still working to resolve the issue of not being able to take credit card payments. ACH payments are working so a policyholder may make an ACH payment. The vendor understands the impact this has on your business and appreciates your patience while they continue to diligently work to resolve this. You can monitor the status here: https://status.bridgepaynetwork.com/ **
Posted Feb 09, 2026 - 08:12 CST

Update

**Update: Reliafund informed us they are still working on resolving the issue with the credit card payments**

Issue: We have been notified of an issue currently affecting credit card payments when using the ReliaFund connection. Our team is working with the vendor. We will continue to provide updates as we learn more.
Posted Feb 06, 2026 - 15:47 CST

Identified

**Update: Reliafund, the payment vendor, is working diligently to resolve the issues affecting their site. At this time they do not have an ETA on when the issues will be resolved.**

Issue: We have been notified of an issue currently affecting credit card payments when using the ReliaFund connection. Our team is investigating and working with the vendor. We will continue to provide updates as we learn more.
Posted Feb 06, 2026 - 10:34 CST

Update

We have been notified of an issue currently affecting credit card payments when using the ReliaFund connection. Our team is investigating and working with the vendor. We will continue to provide updates as we learn more.
Posted Feb 06, 2026 - 10:01 CST

Update

We are continuing to investigate this issue.
Posted Feb 06, 2026 - 09:54 CST

Investigating

We have been notified of an issue currently affecting credit card payments when using the ReliaFund connection. Our team is investigating and working with the vendor. We will continue to provide updates as we learn more.
Posted Feb 06, 2026 - 09:52 CST
This incident affects: Other.