Spectrum Errors

Incident Report for IMT Apps

Resolved

We have resolved the issue affecting the errors in Spectrum. Thank you for your patience.
Posted Jul 14, 2026 - 13:46 CDT

Update

We have been notified of an issue where errors are occurring in Spectrum. Our team is investigating and will continue to provide updates as we learn more.
Posted Jul 14, 2026 - 12:04 CDT

Investigating

We have been notified of an issue where errors are occurring in Spectrum. Our team is investigating and will continue to provide updates as we learn more.
Posted Jul 14, 2026 - 12:03 CDT
This incident affected: Spectrum.