IMT Software Services Spectrum Scheduled Maintenance: Sunday, August 9th 8:00 AM CST

Scheduled for Aug 9, 08:00 - 09:00 CDT

Update

IMT Software Services will be performing routine maintenance on our Spectrum platform Sunday, August 9th, beginning at 8:00 AM CST. During this time, there may be limited access to Spectrum. We estimate the maintenance period to be 1 hour or less.

We apologize for the inconvenience that this may cause. If you have any questions regarding the maintenance window, please reach out to the Support Team at support@imtapps.com.

Kind regards,
The IMT Software Services Team
Posted Aug 06, 2026 - 17:10 CDT

Scheduled

IMT Software Services will be performing routine maintenance on our Spectrum platform Sunday, August 9th, beginning at 8:00 AM CST. During this time, there may be limited access to Spectrum. We estimate the maintenance period to be 1 hour or less.

We apologize for the inconvenience that this may cause. If you have any questions regarding the maintenance window, please reach out to the Support Team at support@imtapps.com.

Kind regards,
The IMT Software Services Team
Posted Aug 06, 2026 - 17:08 CDT
This scheduled maintenance affects: Spectrum.