Quote (Vector): Not able to rate
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting Quote (Vector) for some of our customers. Thank you for your patience.
Posted Jul 22, 2021 - 15:20 CDT
Investigating
We have been notified of an issue currently affecting Quote (Vector) for some of our customers. Our team is investigating and will continue to provide updates as we learn more.
Posted Jul 22, 2021 - 14:25 CDT
This incident affected: Vector.