Online System - Online System is down
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting our online system. Thank you for your patience.
Posted Sep 25, 2019 - 11:08 CDT
Investigating
We have been notified of an issue currently affecting Online System. Our team is investigating and will continue to update you as we learn more.
Posted Sep 25, 2019 - 10:42 CDT
This incident affected: Vector, Claims, Imaging, WebInquiry, Dashboard, Lender Notifications, and Navigator.