Issues with Online Systems

Incident Report for IMT Apps

Resolved

We have resolved the issue affecting our Online Systems. Thank you for your patience.
Posted Dec 30, 2025 - 10:50 CST

Monitoring

We believe we have resolved the issue affecting our Online system. Thank you for your patience. Please let us know if you continue to experience issues.
Posted Dec 30, 2025 - 09:21 CST

Identified

**Update: We have identified the issue that is causing errors with our Online Systems and are working on a resolution.**
Posted Dec 30, 2025 - 09:10 CST

Update

We have been notified of an issue currently affecting our Online Systems (imtapps.com). Our team is investigating and will continue to provide updates as we learn more.
Posted Dec 30, 2025 - 07:54 CST

Investigating

We have been notified of an issue currently affecting our Online Systems (imtapps.com). Our team is investigating and will continue to provide updates as we learn more.
Posted Dec 30, 2025 - 07:51 CST
This incident affected: Quote/Apps (Vector), Claims Management, Imaging, Web Inquiry, Dashboard, Policy Search (Navigator), Spectrum, and Accounting (Spectrum).