Web Inquiry Intermittent Issues
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting Web Inquiry. Thank you for your patience.
Posted Dec 02, 2019 - 10:42 CST
Investigating
We have been notified of intermittent issues currently affecting Web Inquiry. Our team is investigating and will continue to update you as we learn more.
Posted Dec 02, 2019 - 10:09 CST
This incident affected: WebInquiry.