Claims System Unavailable
Incident Report for IMT Apps
Resolved
This incident has been resolved.
Posted Jul 20, 2023 - 15:46 CDT
Monitoring
We believe we have resolved the issue affecting Claims. Thank you for your patience. Please let us know if you continue to experience issues.
Posted Jul 20, 2023 - 15:12 CDT
Update
We have identified the issue impacting the Claims system and are working on a resolution.
Posted Jul 20, 2023 - 13:59 CDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2023 - 13:55 CDT
Identified
We have identified the issue impacting the Claims system and are working on a resolution.
Posted Jul 20, 2023 - 13:54 CDT
This incident affected: Claims.