Slowness in Imaging (Attachments) and Claims

Incident Report for IMT Apps

Resolved

This incident has been resolved.
Posted Apr 03, 2020 - 10:26 CDT

Monitoring

We have been notified of an issue currently affecting the speed in Imaging/Attachments and Claims, potentially displaying errors to users. We have identified the issue and speed will be back to normal shortly. Thank you for your patience.
Posted Apr 03, 2020 - 08:51 CDT
This incident affected: Quote/Apps (Vector), Claims Management, Imaging, and Policy Search (Navigator).