Mutual News Feed and Reset Password Not Working
Incident Report for IMT Apps
Resolved
We have resolved the issues that were affecting Your News Feed (Mutual) not loading and Reset Password Thank you for your patience.
Posted May 24, 2019 - 09:50 CDT
Investigating
We have been notified of issues we are currently having with Your News Feed (Mutual) and Reset Password. Our team is investigating and will continue to update you as we learn more.
Posted May 24, 2019 - 07:44 CDT
This incident affected: Dashboard.