Imaging Responsiveness

Incident Report for IMT Apps

Resolved

We have resolved the issue affecting the speed of some Online Products. Thank you for your patience.
Posted Jul 09, 2025 - 16:08 CDT

Update

We are continuing to investigate this issue.
Posted Jul 09, 2025 - 15:35 CDT

Investigating

We have been notified of an issue currently affecting the speed of some Online Products. Our team is investigating and will continue to provide updates as we learn more.
Posted Jul 09, 2025 - 15:33 CDT
This incident affected: Imaging, Web Inquiry, Policy Search (Navigator), and Spectrum.