IMTAPPS.com Unavailable
Incident Report for IMT Apps
Resolved
This incident has been resolved.
Posted Sep 18, 2023 - 09:56 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 18, 2023 - 09:40 CDT
Identified
We have been notified of an issue currently affecting the imtapps.com site. Our team has identified the issue and systems should be restored shortly.
Posted Sep 18, 2023 - 09:30 CDT
This incident affected: Vector, Claims, Imaging, WebInquiry, Dashboard, Lender Notifications, Other, Navigator, and Spectrum.