IMT Liability Dec Page Downloads
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting IMT Liability Dec Pages. Thank you for your patience.
Posted Nov 07, 2018 - 09:41 CST
Investigating
We have been notified of an issue currently affecting downloading policy print when IMT Liability Dec Pages are attached. Our team is investigating and will continue to update you as we learn more.
Posted Nov 07, 2018 - 08:30 CST
This incident affected: Navigator.