Online Systems are down
Incident Report for IMT Apps
Resolved
We have resolved the issues affecting our Online systems. Thank you for your patience.
Posted Dec 02, 2019 - 09:26 CST
Investigating
We have been notified of an issue currently affecting our Online Products. Our team is investigating and will continue to update you as we learn more.
Posted Dec 02, 2019 - 08:58 CST
This incident affected: Vector, Claims, Imaging, WebInquiry, Dashboard, Lender Notifications, Other, and Navigator.