Online Issues
Incident Report for IMT Apps
Resolved
We have resolved the issue affecting our Online Products. Thank you for your patience.
Posted Jan 11, 2019 - 16:36 CST
Investigating
We have been notified of an issue currently affecting our Online Products. Our team is investigating and will continue to update you as we learn more.
Posted Jan 11, 2019 - 15:59 CST
This incident affected: Vector, WebInquiry, Lender Notifications, Other, and Navigator.